$re = '/\[caption[^]]+]\R?/';
$str = '[caption id="attachment_24612" align="alignnone" width="900"]
Other text';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;