re = /\[caption[^]]+]\R?/
str = '[caption id="attachment_24612" align="alignnone" width="900"]
Other text'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result