import Foundation
let pattern = #"\[caption[^]]+]\R?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[caption id="attachment_24612" align="alignnone" width="900"]
Other text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)