import re
regex = re.compile(r"\[caption[^]]+]\R?")
test_str = ("[caption id=\"attachment_24612\" align=\"alignnone\" width=\"900\"]\n"
"Other text")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)