use strict;
my $str = '[caption id="attachment_24612" align="alignnone" width="900"]
Other text';
my $regex = qr/\[caption[^]]+]\R?/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";