const regex = /\[caption[^]]+]\R?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[caption[^]]+]\\R?', 'g')
const str = `[caption id="attachment_24612" align="alignnone" width="900"]
Other text`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);