#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[caption[^]]+]\R?"
Local $sString = "[caption id="attachment_24612" align="alignnone" width="900"]" & @CRLF & _
"Other text"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)