# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:[$,]*)(([0-9.]{1,3})(?:[,.]?))+(?:[$,]*)$/$/gmi;t' <<< "$100
240
234.00
234,092
250,000,000.00
23june23
08APR934"