use strict;
my $str = '$100
240
234.00
234,092
250,000,000.00
23june23
08APR934';
my $regex = qr/^(?:[$,]*)(([0-9.]{1,3})(?:[,.]?))+(?:[$,]*)$/mip;
my $subst = '$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";