using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[$,]*)(([0-9.]{1,3})(?:[,.]?))+(?:[$,]*)$";
string substitution = @"$";
string input = @"$100
240
234.00
234,092
250,000,000.00
23june23
08APR934";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}