import Foundation
let pattern = #"^(?:[$,]*)(([0-9.]{1,3})(?:[,.]?))+(?:[$,]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
$100
240
234.00
234,092
250,000,000.00
23june23
08APR934
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)