import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[$,]*)(([0-9.]{1,3})(?:[,.]?))+(?:[$,]*)$";
final String string = "$100\n"
+ "240\n"
+ "234.00\n"
+ "234,092\n"
+ "250,000,000.00\n"
+ "23june23\n"
+ "08APR934";
final String subst = "$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}