import re
regex = re.compile(r"^(?:[$,]*)(([0-9.]{1,3})(?:[,.]?))+(?:[$,]*)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("$100\n"
"240\n"
"234.00\n"
"234,092\n"
"250,000,000.00\n"
"23june23\n"
"08APR934")
subst = "$"
result = regex.sub(subst, test_str)
if result:
print(result)