#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\{([a-z_]\w*)\}"
Local $sString = "Original example:" & @CRLF & _
"{login}:{password}:{ip}" & @CRLF & _
"" & @CRLF & _
"What about other field names? `e-mail` would be acceptable depending on the DB but it's" & @CRLF & _
"probably not a good idea to create field names with special chars." & @CRLF & _
"{_ipv6},{name},{e-mail},{1_not_ok_with_leading_numbers}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")