import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{([a-z_]\\w*)\\}";
final String string = "Original example:\n"
+ "{login}:{password}:{ip}\n\n"
+ "What about other field names? `e-mail` would be acceptable depending on the DB but it's\n"
+ "probably not a good idea to create field names with special chars.\n"
+ "{_ipv6},{name},{e-mail},{1_not_ok_with_leading_numbers}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}