re = /\{([a-z_]\w*)\}/i
str = 'Original example:
{login}:{password}:{ip}
What about other field names? `e-mail` would be acceptable depending on the DB but it\'s
probably not a good idea to create field names with special chars.
{_ipv6},{name},{e-mail},{1_not_ok_with_leading_numbers}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end