import re
regex = re.compile(r"\{([a-z_]\w*)\}", flags=re.IGNORECASE)
test_str = ("Original example:\n"
"{login}:{password}:{ip}\n\n"
"What about other field names? `e-mail` would be acceptable depending on the DB but it's\n"
"probably not a good idea to create field names with special chars.\n"
"{_ipv6},{name},{e-mail},{1_not_ok_with_leading_numbers}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")