const regex = /\{([a-z_]\w*)\}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{([a-z_]\\w*)\\}', 'gi')
const str = `Original example:
{login}:{password}:{ip}
What about other field names? \`e-mail\` would be acceptable depending on the DB but it's
probably not a good idea to create field names with special chars.
{_ipv6},{name},{e-mail},{1_not_ok_with_leading_numbers}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}