// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\{([a-z_]\w*)\}").unwrap();
let string = "Original example:
{login}:{password}:{ip}
What about other field names? `e-mail` would be acceptable depending on the DB but it's
probably not a good idea to create field names with special chars.
{_ipv6},{name},{e-mail},{1_not_ok_with_leading_numbers}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}