#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\.?\d{1,5}(?:\.\d{1,5})*$"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"1234" & @CRLF & _
"12345" & @CRLF & _
"123456" & @CRLF & _
"1.2" & @CRLF & _
".1" & @CRLF & _
".1.2" & @CRLF & _
"1234567890" & @CRLF & _
"1234567890." & @CRLF & _
"12345.67890" & @CRLF & _
".1234567890" & @CRLF & _
"123.4567.890" & @CRLF & _
".1234567890." & @CRLF & _
"12345..67890" & @CRLF & _
".1234.567890." & @CRLF & _
"1.234.567.890" & @CRLF & _
".123.456.7890" & @CRLF & _
".1.2.3.4.5.6.7.8.9.0" & @CRLF & _
".1.2.3.4.5.6.7.8.9.0."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")