import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\.?\\d{1,5}(?:\\.\\d{1,5})*$";
final String string = "1\n"
+ "12\n"
+ "123\n"
+ "1234\n"
+ "12345\n"
+ "123456\n"
+ "1.2\n"
+ ".1\n"
+ ".1.2\n"
+ "1234567890\n"
+ "1234567890.\n"
+ "12345.67890\n"
+ ".1234567890\n"
+ "123.4567.890\n"
+ ".1234567890.\n"
+ "12345..67890\n"
+ ".1234.567890.\n"
+ "1.234.567.890\n"
+ ".123.456.7890\n"
+ ".1.2.3.4.5.6.7.8.9.0\n"
+ ".1.2.3.4.5.6.7.8.9.0.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}