import Foundation
let pattern = #"^\.?\d{1,5}(?:\.\d{1,5})*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1
12
123
1234
12345
123456
1.2
.1
.1.2
1234567890
1234567890.
12345.67890
.1234567890
123.4567.890
.1234567890.
12345..67890
.1234.567890.
1.234.567.890
.123.456.7890
.1.2.3.4.5.6.7.8.9.0
.1.2.3.4.5.6.7.8.9.0.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)