use strict;
my $str = '1
12
123
1234
12345
123456
1.2
.1
.1.2
1234567890
1234567890.
12345.67890
.1234567890
123.4567.890
.1234567890.
12345..67890
.1234.567890.
1.234.567.890
.123.456.7890
.1.2.3.4.5.6.7.8.9.0
.1.2.3.4.5.6.7.8.9.0.';
my $regex = qr/^\.?\d{1,5}(?:\.\d{1,5})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}