package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\.?\d{1,5}(?:\.\d{1,5})*$`)
var str = `1
12
123
1234
12345
123456
1.2
.1
.1.2
1234567890
1234567890.
12345.67890
.1234567890
123.4567.890
.1234567890.
12345..67890
.1234.567890.
1.234.567.890
.123.456.7890
.1.2.3.4.5.6.7.8.9.0
.1.2.3.4.5.6.7.8.9.0.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}