// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\.?\d{1,5}(?:\.\d{1,5})*$").unwrap();
let string = "1
12
123
1234
12345
123456
1.2
.1
.1.2
1234567890
1234567890.
12345.67890
.1234567890
123.4567.890
.1234567890.
12345..67890
.1234.567890.
1.234.567.890
.123.456.7890
.1.2.3.4.5.6.7.8.9.0
.1.2.3.4.5.6.7.8.9.0.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}