# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/url:\h"\K[^"]+(?=\/ajax\/ads)/ЗначениеДляЗамены/gm;t' <<< "$.ajax({type: \"POST\",url: \"/dir1/dir2/ajax/ads\",data: \"view=list\",dataType: \"html\",cache: false,success: function (data) {
}});"