use strict;
my $str = '$.ajax({type: "POST",url: "/dir1/dir2/ajax/ads",data: "view=list",dataType: "html",cache: false,success: function (data) {
}});';
my $regex = qr~url:\h"\K[^"]+(?=/ajax/ads)~mp;
my $subst = 'ЗначениеДляЗамены';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";