import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url:\\h\"\\K[^\"]+(?=/ajax/ads)";
final String string = "$.ajax({type: \"POST\",url: \"/dir1/dir2/ajax/ads\",data: \"view=list\",dataType: \"html\",cache: false,success: function (data) { \n"
+ "}});";
final String subst = "ЗначениеДляЗамены";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}