import Foundation
let pattern = #"url:\h"\K[^"]+(?=/ajax/ads)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$.ajax({type: "POST",url: "/dir1/dir2/ajax/ads",data: "view=list",dataType: "html",cache: false,success: function (data) {
}});
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"ЗначениеДляЗамены"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)