# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"url:\h\"\K[^\"]+(?=/ajax/ads)"
test_str = ("$.ajax({type: \"POST\",url: \"/dir1/dir2/ajax/ads\",data: \"view=list\",dataType: \"html\",cache: false,success: function (data) { \n"
"}});")
subst = "ЗначениеДляЗамены"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.