using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url:\h""\K[^""]+(?=/ajax/ads)";
string substitution = @"ЗначениеДляЗамены";
string input = @"$.ajax({type: ""POST"",url: ""/dir1/dir2/ajax/ads"",data: ""view=list"",dataType: ""html"",cache: false,success: function (data) {
}});";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}