using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\"".*\\(.+)[\r\n](.*)\""";
string input = @"""c:\users\jdoe\OneDrive\Folder 1\Folder 2\File 1.pdf
File 1.pdf""
""c:\users\jdoe\OneDrive\Folder 1\Folder 2\File 2.pdf
File 2.pdf""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}