const regex = /\".*\\(.+)[\r\n](.*)\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\".*\\\\(.+)[\\r\\n](.*)\\"', 'gm')
const str = `"c:\\users\\jdoe\\OneDrive\\Folder 1\\Folder 2\\File 1.pdf
File 1.pdf"
"c:\\users\\jdoe\\OneDrive\\Folder 1\\Folder 2\\File 2.pdf
File 2.pdf"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}