package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\".*\\(.+)[\r\n](.*)\"`)
var str = `"c:\users\jdoe\OneDrive\Folder 1\Folder 2\File 1.pdf
File 1.pdf"
"c:\users\jdoe\OneDrive\Folder 1\Folder 2\File 2.pdf
File 2.pdf"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}