import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\".*\\\\(.+)[\\r\\n](.*)\\\"";
final String string = "\"c:\\users\\jdoe\\OneDrive\\Folder 1\\Folder 2\\File 1.pdf\n"
+ "File 1.pdf\"\n"
+ "\"c:\\users\\jdoe\\OneDrive\\Folder 1\\Folder 2\\File 2.pdf\n"
+ "File 2.pdf\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}