$re = '/\".*\\\\(.+)[\r\n](.*)\"/m';
$str = '"c:\\users\\jdoe\\OneDrive\\Folder 1\\Folder 2\\File 1.pdf
File 1.pdf"
"c:\\users\\jdoe\\OneDrive\\Folder 1\\Folder 2\\File 2.pdf
File 2.pdf"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);