re = /\".*\\(.+)[\r\n](.*)\"/m
str = '"c:\\users\\jdoe\\OneDrive\\Folder 1\\Folder 2\\File 1.pdf
File 1.pdf"
"c:\\users\\jdoe\\OneDrive\\Folder 1\\Folder 2\\File 2.pdf
File 2.pdf"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end