# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!.*\\/products(?:\\/))(?:(.*)\\/|$)?(?:child)$/$1\/children/gm;t' <<< "https://products.domain.com/products/
https://products.domain.com/products/family/child
https://products.domain.com/family/children
https://products.domain.com/products/family/children
https://products.domain.com/family/child"