import Foundation
let pattern = #"^(?!.*\/products(?:\/))(?:(.*)\/|$)?(?:child)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://products.domain.com/products/
https://products.domain.com/products/family/child
https://products.domain.com/family/children
https://products.domain.com/products/family/children
https://products.domain.com/family/child
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1/children"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)