use strict;
my $str = 'https://products.domain.com/products/
https://products.domain.com/products/family/child
https://products.domain.com/family/children
https://products.domain.com/products/family/children
https://products.domain.com/family/child';
my $regex = qr/^(?!.*\/products(?:\/))(?:(.*)\/|$)?(?:child)$/mp;
my $subst = '$1/children';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";