#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!.*\/products(?:\/))(?:(.*)\/|$)?(?:child)$"
Local $sString = "https://products.domain.com/products/" & @CRLF & _
"https://products.domain.com/products/family/child" & @CRLF & _
"https://products.domain.com/family/children" & @CRLF & _
"https://products.domain.com/products/family/children" & @CRLF & _
"https://products.domain.com/family/child"
Local $sSubst = "$1/children"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)