# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*\/products(?:\/))(?:(.*)\/|$)?(?:child)$"
test_str = ("https://products.domain.com/products/\n"
"https://products.domain.com/products/family/child\n"
"https://products.domain.com/family/children\n"
"https://products.domain.com/products/family/children\n"
"https://products.domain.com/family/child")
subst = "$1/children"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.