import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\/products(?:\\/))(?:(.*)\\/|$)?(?:child)$";
final String string = "https://products.domain.com/products/\n"
+ "https://products.domain.com/products/family/child\n"
+ "https://products.domain.com/family/children\n"
+ "https://products.domain.com/products/family/children\n"
+ "https://products.domain.com/family/child";
final String subst = "$1/children";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}