# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\b(s)(?=tupid\b)|(?!\A)\G)\pL/$1-/g;t' <<< "hello, i think you are not intelligent, you are actually dumb and stupid."