#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\b(s)(?=tupid\b)|(?!\A)\G)\pL"
Local $sString = "hello, i think you are not intelligent, you are actually dumb and stupid."
Local $sSubst = "$1-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)