using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b(s)(?=tupid\b)|(?!\A)\G)\pL";
string substitution = @"$1-";
string input = @"hello, i think you are not intelligent, you are actually dumb and stupid.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}