import Foundation
let pattern = #"(?:\b(s)(?=tupid\b)|(?!\A)\G)\pL"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"hello, i think you are not intelligent, you are actually dumb and stupid."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)