use strict;
my $str = 'hello, i think you are not intelligent, you are actually dumb and stupid.';
my $regex = qr/(?:\b(s)(?=tupid\b)|(?!\A)\G)\pL/p;
my $subst = '$1-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";