const regex = /(?:\b(s)(?=tupid\b)|(?!\A)\G)\pL/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b(s)(?=tupid\\b)|(?!\\A)\\G)\\pL', 'g')
const str = `hello, i think you are not intelligent, you are actually dumb and stupid.`;
const subst = `$1-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);