$re = '/(?:\b(s)(?=tupid\b)|(?!\A)\G)\pL/';
$str = 'hello, i think you are not intelligent, you are actually dumb and stupid.';
$subst = "$1-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;